Weblogic Managed Server startup without giving userid/password everytime

When you start the weblogic managed servers, it asks for userid/password to startup. This is unlike the Admin server which doesn’t ask everytime you start, the creadentials are saved somewhere.
It would be quite helpful if the same happens for the Managed servers as well. The way you save credentials to the managed servers is very simple
Navigate to
1. /user_projects/domains//servers/
2. create a folder “security”, if doesn’t exist
3. create a file boot.properties
4. add the following lines
username=weblogic
password= and save it.
That is it.
The next time you start the managed server, it automatically reads this file, and gets the credentials
You can also find these lines in the startup logs which shows it gets the credentials from just created file
This entry was posted in Uncategorized. Bookmark the permalink.

1 Response to Weblogic Managed Server startup without giving userid/password everytime

  1. Ganesh says:

    The other way to save the credentials of a managed server is

    You can find the below lines in the startManagedWebLogic.cmd file in user_projects/domain/soa-domain/bin folder

    Just enter the user and password of WLS in the below lines and save it. It won't prompt next time when you start the manged server

    ===================================
    @REM prompt.

    set WLS_USER=

    set WLS_PW=
    ===================================

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s